Below are some excerpts from one of the switches in question. Using the NAV "Configure Ports" button from the device page to get the entire list of ports, I set the name of g1/0/30 to "NAV Test" and the VLAN to 501. The same result is seen while using the "Configure Port" button from the specific port page.

"Before" shows that g1/0/30 is not in VLAN 501 and has no description using "show vlan id", "sh run int" and "sh int desc".

"After" shows that "sh vlan id" has g1/0/30 in vlan 501 and that "sh int desc" has the correct description while a "show run int" does not reflect these changes.

#sh ver
Cisco IOS Software, IOS-XE Software, Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version 03.06.01E RELEASE SOFTWARE (fc3)

Before:

#sh vlan id 501
...
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
501 wla-adi1 active Po1
...

#sh run int g1/0/30
...
interface GigabitEthernet1/0/30
switchport mode access
power inline never
spanning-tree portfast
service-policy input Policy-3850-Input
end

#sh int description | inc 30
Gi1/0/30 down down
...

After:

#sh vlan id 501

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
501 wla-adi1 active Gi1/0/30, Po1


#sh run int g1/0/30
...
interface GigabitEthernet1/0/30
switchport mode access
power inline never
spanning-tree portfast
service-policy input Policy-3850-Input
end

#sh int description | inc 30
Gi1/0/30 admin down down NAV Test
...

Hope this helps. Please let me know if you would like additional output or diagnostics.

BTW, has anyone tried this on any other platform (not just 3850) using IOS XE 3.6.1E or something close?

On Tue, Dec 16, 2014 at 12:14 AM, Morten Brekkevold <morten.brekkevold@uninett.no> wrote:
On Mon, 15 Dec 2014 11:21:00 +0100 John Magne Bredal <john.m.bredal@uninett.no> wrote:

> Another troubling trend is that later versions of Cisco software has
> stopped supporting SNMP for configuring devices and now requires NETCONF
> for such tasks.

I'd like to point out that we only heard this about NX-OS software (Cisco
Nexus products). We don't know yet that they have the same plans for IOS.

What would be interesting, Ken Tobias, is to know the two software
versions of your working and your not-entirely-working 3850's.

Also, one of our network engineers was interested in seeing an example
difference in output between `show vlan` and `show running` which
demonstrates the "ephemeral" setting of VLANs you mentioned. He'd never
heard of such a thing :-)


--
Morten Brekkevold
UNINETT